Dreamweaver Server RAD Tools Multiple Unspecified SQL Injection

2006-05-09T06:47:37
ID OSVDB:25361
Type osvdb
Reporter Brian Gallagher(brian@diamondsea.com)
Modified 2006-05-09T06:47:37

Description

Vulnerability Description

Dreamweaver contains a flaw that may allow an attacker to carry out an SQL injection attack. The issue is due to scripts generated for the ColdFusion, PHP mySQL, ASP, ASP.NET, and JSP server models failing to properly sanitize user-supplied input to the various unspecified variables. This may allow an attacker to inject or manipulate SQL queries in the backend database.

Solution Description

Upgrade to version 8.0.2 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

Short Description

Dreamweaver contains a flaw that may allow an attacker to carry out an SQL injection attack. The issue is due to scripts generated for the ColdFusion, PHP mySQL, ASP, ASP.NET, and JSP server models failing to properly sanitize user-supplied input to the various unspecified variables. This may allow an attacker to inject or manipulate SQL queries in the backend database.

References:

Vendor Specific Advisory URL Secunia Advisory ID:20054 Mail List Post: http://archives.neohapsis.com/archives/bugtraq/2006-05/0194.html ISS X-Force ID: 26339 CVE-2006-2042 Bugtraq ID: 17928