PassMasterFlexPlus User-Agent HTTP Header Field XSS

2006-05-06T07:02:41
ID OSVDB:25302
Type osvdb
Reporter Nomenumbra/[0x4F4C](zerogue@gmail.com)
Modified 2006-05-06T07:02:41

Description

Vulnerability Description

PassMasterFlexPlus contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate the HTTP User-Agent header field upon displaying it in the application log files. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server when that user is viewing the log files, leading to a loss of integrity.

Solution Description

Currently, there are no known upgrades, patches, or workarounds available to correct this issue.

Short Description

PassMasterFlexPlus contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate the HTTP User-Agent header field upon displaying it in the application log files. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server when that user is viewing the log files, leading to a loss of integrity.

References:

Vendor URL: http://www.lethalpenguin.net/design/passmasterflexplus.php Secunia Advisory ID:20020 Mail List Post: http://archives.neohapsis.com/archives/bugtraq/2006-05/0108.html ISS X-Force ID: 26298 FrSIRT Advisory: ADV-2006-1696 CVE-2006-2340