KCScripts Portal Pack news/NsVisitor.cgi sort_order Variable XSS

2006-04-20T04:04:05
ID OSVDB:24762
Type osvdb
Reporter r0t(krustevs@googlemail.com)
Modified 2006-04-20T04:04:05

Description

Vulnerability Description

KCScripts Portal Pack contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate the 'sort_order' variable upon submission to the 'news/NsVisitor' script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

Solution Description

Currently, there are no known upgrades, patches, or workarounds available to correct this issue.

Short Description

KCScripts Portal Pack contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate the 'sort_order' variable upon submission to the 'news/NsVisitor' script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

Manual Testing Notes

/cgi-bin/news/NsVisitor.cgi?job=view_article&articleNo=0&sort_order=[XSS]

References:

Vendor URL: http://www.kcscripts.com/scripts/portal-pack.htm Secunia Advisory ID:19695 Related OSVDB ID: 24763 Related OSVDB ID: 24764 Related OSVDB ID: 24761 Other Advisory URL: http://pridels.blogspot.com/2006/04/portal-pack-6-xss-vuln.html ISS X-Force ID: 25940 CVE-2006-1968