RechnungsZentrale V2 mod/authent.php4 user Variable SQL Injection

2006-04-18T09:47:34
ID OSVDB:24752
Type osvdb
Reporter GroundZero Security Research and Software Development(info@g-0.org)
Modified 2006-04-18T09:47:34

Description

Vulnerability Description

RechnungsZentrale V2 contains a flaw that may allow an attacker to carry out an SQL injection attack. The issue is due to the mod/authent.php4 script not properly sanitizing user-supplied input to the 'user' variable. This may allow an attacker to inject or manipulate SQL queries in the backend database.

Technical Description

This vulnerability is only present when the magic_quotes_gpc PHP option is 'off' and the register_globals PHP option is 'on'.

Solution Description

Currently, there are no known upgrades, patches, or workarounds available to correct this issue.

Short Description

RechnungsZentrale V2 contains a flaw that may allow an attacker to carry out an SQL injection attack. The issue is due to the mod/authent.php4 script not properly sanitizing user-supplied input to the 'user' variable. This may allow an attacker to inject or manipulate SQL queries in the backend database.

Manual Testing Notes

User: ' OR '1'='1 Password: 1

References:

Vendor URL: http://www.nfec.de/ Secunia Advisory ID:19728 Related OSVDB ID: 24753 Other Advisory URL: http://www.g-0.org/code/rz2-adv.html Mail List Post: http://archives.neohapsis.com/archives/bugtraq/2006-04/0384.html ISS X-Force ID: 25911 FrSIRT Advisory: ADV-2006-1425 CVE-2006-1954 Bugtraq ID: 17588