[V]Book config.php Arbitrary PHP Code Execution

2006-03-29T04:02:39
ID OSVDB:24272
Type osvdb
Reporter Aliaksandr Hartsuyeu(alex@evuln.com)
Modified 2006-03-29T04:02:39

Description

Vulnerability Description

[V]Book contains a flaw that may allow a remote attacker to execute arbitrary code. The issue occurs because program administrators are allowed to edit the config.php file. By placing custom PHP code and then calling it, the code will be executed with the privileges of the web server.

Technical Description

An attacker must supply valid administrator authentication credentials in order to exploit this vulnerability.

This vulnerability is only present when the magic_quotes_gpc PHP option is 'off'.

Solution Description

Currently, there are no known upgrades, patches, or workarounds available to correct this issue.

Short Description

[V]Book contains a flaw that may allow a remote attacker to execute arbitrary code. The issue occurs because program administrators are allowed to edit the config.php file. By placing custom PHP code and then calling it, the code will be executed with the privileges of the web server.

References:

Vendor URL: http://www.vscripts.pl/?id=vbook2 Secunia Advisory ID:19448 Related OSVDB ID: 24270 Related OSVDB ID: 24271 Other Advisory URL: http://evuln.com/vulns/111/summary.html Mail List Post: http://archives.neohapsis.com/archives/bugtraq/2006-04/0208.html Keyword: EV0111 ISS X-Force ID: 25522 FrSIRT Advisory: ADV-2006-1174 CVE-2006-1563