DSPoll include/pollit.php pollid Variable SQL Injection

2006-03-12T08:47:39
ID OSVDB:23881
Type osvdb
Reporter Aliaksandr Hartsuyeu(alex@evuln.com)
Modified 2006-03-12T08:47:39

Description

Vulnerability Description

DSPoll contains a flaw that may allow an attacker to carry out an SQL injection attack. The issue is due to the include/pollit.php script not properly sanitizing user-supplied input to the 'pollid' variable. This may allow an attacker to inject or manipulate SQL queries in the backend database.

Technical Description

This vulnerability is only present when the magic_quotes_gpc PHP option is 'off'.

Solution Description

Currently, there are no known upgrades, patches, or workarounds available to correct this issue.

Short Description

DSPoll contains a flaw that may allow an attacker to carry out an SQL injection attack. The issue is due to the include/pollit.php script not properly sanitizing user-supplied input to the 'pollid' variable. This may allow an attacker to inject or manipulate SQL queries in the backend database.

References:

Vendor URL: http://dsportal.uw.hu/ Security Tracker: 1015758 Secunia Advisory ID:19209 Related OSVDB ID: 23880 Related OSVDB ID: 23879 Other Advisory URL: http://evuln.com/vulns/96/summary.html Mail List Post: http://archives.neohapsis.com/archives/bugtraq/2006-03/0462.html Keyword: EV0096 CVE-2006-1217