SPIP spip_login.php3 XSS

2005-12-21T09:33:27
ID OSVDB:21864
Type osvdb
Reporter r0t(krustevs@googlemail.com)
Modified 2005-12-21T09:33:27

Description

Vulnerability Description

SPIP contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate variables upon submission to the spip_login.php3 script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

Solution Description

Currently, there are no known upgrades, patches, or workarounds available to correct this issue.

Short Description

SPIP contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate variables upon submission to the spip_login.php3 script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

References:

Vendor URL: http://www.spip.net/en Secunia Advisory ID:18211 Related OSVDB ID: 21865 Other Advisory URL: http://pridels.blogspot.com/2005/12/spip-xss-vuln.html CVE-2005-4494 Bugtraq ID: 16019