kPlaylist searchfor Variable XSS

2005-11-23T11:12:35
ID OSVDB:21069
Type osvdb
Reporter r0t(krustevs@googlemail.com)
Modified 2005-11-23T11:12:35

Description

Vulnerability Description

kPlaylist contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate "searchfor" variable upon submission to the kPlaylist script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

Solution Description

Upgrade to build 1.6 412 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

Short Description

kPlaylist contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate "searchfor" variable upon submission to the kPlaylist script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

Manual Testing Notes

POST: http://[target]/kplaylist.php action=search&searchfor=[XSS]&searchwh=0&hitsas=0&startsearch=Search

References:

Vendor URL: http://www.kplaylist.net/ Secunia Advisory ID:17689 Other Advisory URL: http://pridels.blogspot.com/2005/11/kplaylist-xss-vuln.html FrSIRT Advisory: ADV-2005-2551 CVE-2005-3841 Bugtraq ID: 15546