GNUMP3d Error Page XSS

2005-10-28T11:02:35
ID OSVDB:20359
Type osvdb
Reporter Steve Kemp()
Modified 2005-10-28T11:02:35

Description

Vulnerability Description

GNUMP3d contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate URLs before returning them in a 404 error page. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

Solution Description

Upgrade to version 2.9.6 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

Short Description

GNUMP3d contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate URLs before returning them in a 404 error page. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

References:

Vendor URL: http://www.gnu.org/software/gnump3d/ Security Tracker: 1015118 Secunia Advisory ID:17351 Secunia Advisory ID:17355 Secunia Advisory ID:17831 Related OSVDB ID: 20723 Related OSVDB ID: 20360 Other Advisory URL: http://www.debian.org/security/2005/dsa-877 Other Advisory URL: http://lists.suse.com/archive/suse-security-announce/2005-Dec/0001.html Keyword: DSA-877-1 CVE-2005-3424 Bugtraq ID: 15226