Simplog archive.php Multiple Variable SQL Injection

2005-09-09T12:23:28
ID OSVDB:19581
Type osvdb
Reporter r0ut3r()
Modified 2005-09-09T12:23:28

Description

Vulnerability Description

Simplog contains a flaw that may allow an attacker to carry out an SQL injection attack. The issue is due to the archive.php script not properly sanitizing user-supplied input to the 'pid' and 'cid' variables. This may allow an attacker to inject or manipulate SQL queries in the backend database.

Solution Description

Upgrade to version 0.9.2 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

Short Description

Simplog contains a flaw that may allow an attacker to carry out an SQL injection attack. The issue is due to the archive.php script not properly sanitizing user-supplied input to the 'pid' and 'cid' variables. This may allow an attacker to inject or manipulate SQL queries in the backend database.

Manual Testing Notes

/simplog/archive.php?blogid=1&pid=a /simplog/archive.php?m=08&y=2005&blogid=1a /simplog/archive.php?blogid=1&y=2004&m='01 /simplog/archive.php?blogid=1&cid='3

References:

Vendor Specific News/Changelog Entry: http://www.simplog.org/bugs/bug.php?op=show&bugid=55 Secunia Advisory ID:16881 Related OSVDB ID: 19582 CVE-2005-3076 Bugtraq ID: 14897