vBulletin /admincp/user.php Multiple Variable SQL Injection

2005-09-17T13:14:34
ID OSVDB:19535
Type osvdb
Reporter Thomas Waldegger(bugtraq@morph3us.org)
Modified 2005-09-17T13:14:34

Description

Vulnerability Description

vBulletin contains a flaw that may allow an attacker to carry out an SQL injection attack. The issue is due to the /admincp/user.php script not properly sanitizing user-supplied input to the 'limitnumber' or 'limitstart' variable. This may allow an attacker to inject or manipulate SQL queries in the backend database.

Solution Description

Upgrade to version 3.0.9 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

Short Description

vBulletin contains a flaw that may allow an attacker to carry out an SQL injection attack. The issue is due to the /admincp/user.php script not properly sanitizing user-supplied input to the 'limitnumber' or 'limitstart' variable. This may allow an attacker to inject or manipulate SQL queries in the backend database.

References:

Vendor URL: http://vbulletin.com/ Vendor Specific News/Changelog Entry: http://www.vbulletin.com/forum/showthread.php?p=961409 Secunia Advisory ID:16873 Related OSVDB ID: 19537 Related OSVDB ID: 19538 Related OSVDB ID: 19546 Related OSVDB ID: 19990 Related OSVDB ID: 19536 Related OSVDB ID: 19988 Related OSVDB ID: 19534 Related OSVDB ID: 19544 Related OSVDB ID: 19545 Related OSVDB ID: 19989 Other Advisory URL: http://morph3us.org/advisories/20050917-vbulletin-3.0.8.txt Mail List Post: http://archives.neohapsis.com/archives/bugtraq/2005-09/0224.html Keyword: BuHa Security-Advisory #3 ISS X-Force ID: 22323 CVE-2005-3024 CVE-2005-3019 Bugtraq ID: 14872