phpSurveyor browse.php Multiple Variable XSS

2005-07-19T09:56:04
ID OSVDB:18095
Type osvdb
Reporter tgo(thegreatone2176@yahoo.com)
Modified 2005-07-19T09:56:04

Description

Vulnerability Description

phpSurveyor contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate the 'sid', 'start', or 'id' variables upon submission to the browse.php script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

Solution Description

Currently, there are no known upgrades, patches, or workarounds available to correct this issue.

Short Description

phpSurveyor contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate the 'sid', 'start', or 'id' variables upon submission to the browse.php script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

References:

Vendor URL: http://phpsurveyor.org/ Security Tracker: 1014538 Secunia Advisory ID:16123 Related OSVDB ID: 18096 Related OSVDB ID: 18086 Related OSVDB ID: 18097 Related OSVDB ID: 18098 Mail List Post: http://archives.neohapsis.com/archives/bugtraq/2005-07/0326.html CVE-2005-2380