FlatNuke index.php where Variable Path Disclosure

2005-06-06T09:24:41
ID OSVDB:17169
Type osvdb
Reporter OSVDB
Modified 2005-06-06T09:24:41

Description

Vulnerability Description

FlatNuke contains a flaw that may lead to an unauthorized information disclosure. The issue is triggered when sending a specially crafted request to the "index.php" script, which will disclose the installation path resulting in a loss of confidentiality.

Solution Description

Upgrade to version 2.5.4 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

Short Description

FlatNuke contains a flaw that may lead to an unauthorized information disclosure. The issue is triggered when sending a specially crafted request to the "index.php" script, which will disclose the installation path resulting in a loss of confidentiality.

Manual Testing Notes

http://[victim]/flatnuke/index.php?mod=none_Search&find=1&where=null

References:

Vendor URL: http://flatnuke.sourceforge.net/ Security Tracker: 1014114 Secunia Advisory ID:15603 Related OSVDB ID: 17167 Related OSVDB ID: 17172 Related OSVDB ID: 17165 Related OSVDB ID: 17166 Related OSVDB ID: 17170 Related OSVDB ID: 17168 Related OSVDB ID: 17171 Other Advisory URL: http://secwatch.org/advisories/secwatch/20050604_flatnuke.txt CVE-2005-1893 Bugtraq ID: 13882