FlatNuke help.php Multiple Variable XSS

2005-06-06T09:24:41
ID OSVDB:17167
Type osvdb
Reporter OSVDB
Modified 2005-06-06T09:24:41

Description

Vulnerability Description

FlatNuke contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate 'border' and 'back' variables upon submission to the help.php script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

Technical Description

Successful exploitation requires that "register_globals" is enabled.

Solution Description

Upgrade to version 2.5.4 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

Short Description

FlatNuke contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate 'border' and 'back' variables upon submission to the help.php script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

Manual Testing Notes

http://[victim]/forum/help.php?border=%22%3E%3Cscript%3Ealert(document.cookie)%3C/script%3E http://[victim]/forum/help.php?back=%22%3E%3Cscript%3Ealert(document.cookie)%3C/script%3E

References:

Vendor URL: http://flatnuke.sourceforge.net/ Security Tracker: 1014114 Secunia Advisory ID:15603 Related OSVDB ID: 17172 Related OSVDB ID: 17165 Related OSVDB ID: 17166 Related OSVDB ID: 17169 Related OSVDB ID: 17170 Related OSVDB ID: 17168 Related OSVDB ID: 17171 Other Advisory URL: http://secwatch.org/advisories/secwatch/20050604_flatnuke.txt CVE-2005-1895 Bugtraq ID: 13882