yappa-ng admin_module_info.inc.php lang_akt Variable XSS

2005-05-11T05:23:07
ID OSVDB:16546
Type osvdb
Reporter James Bercegay()
Modified 2005-05-11T05:23:07

Description

Vulnerability Description

yappa-ng contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate the 'lang_akt' variable upon submission to the admin_module_info.inc.php script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

Solution Description

Upgrade to version 2.3.2 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

Short Description

yappa-ng contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate the 'lang_akt' variable upon submission to the admin_module_info.inc.php script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

Manual Testing Notes

http://[victim]/admin_modules/admin_module_info.inc.php?lang_akt[admin_ainfo_hmain]=[XSS]

References:

Vendor URL: http://sourceforge.net/projects/yappa-ng/ Vendor Specific Solution URL: https://sourceforge.net/project/showfiles.php?group_id=70802 Vendor Specific News/Changelog Entry: https://sourceforge.net/project/shownotes.php?release_id=323206 Related OSVDB ID: 16548 Related OSVDB ID: 16547 Other Advisory URL: http://www.gulftech.org/?node=research&article_id=00074-05112005 Mail List Post: http://archives.neohapsis.com/archives/bugtraq/2005-05/0141.html