PwsPHP Stats Module Multiple Variable XSS

2005-05-07T09:10:20
ID OSVDB:16229
Type osvdb
Reporter SecuBox fRoGGz(unsecure@writeme.com)
Modified 2005-05-07T09:10:20

Description

Vulnerability Description

PwsPHP contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate the 'nbractif' or 'annee' variables upon submission to the Stats module. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

Solution Description

Upgrade to version 1.2.3 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

Short Description

PwsPHP contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate the 'nbractif' or 'annee' variables upon submission to the Stats module. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

Manual Testing Notes

./index.php?mod=stats&aff=forum&nbractif=[XSS INJECTION] ./index.php?mod=stats&aff=pages&annee=[XSS INJECTION]

References:

Vendor URL: http://www.pwsphp.com/ Security Tracker: 1013935 Secunia Advisory ID:15315 Related OSVDB ID: 16228 Related OSVDB ID: 16232 Related OSVDB ID: 16233 Related OSVDB ID: 16230 Related OSVDB ID: 16231 Related OSVDB ID: 16234 Related OSVDB ID: 16236 Related OSVDB ID: 16235 Mail List Post: http://archives.neohapsis.com/archives/bugtraq/2005-05/0090.html CVE-2005-1508