Horde Forwards Module Parent Frame Page Title XSS

2005-04-25T22:35:48
ID OSVDB:15769
Type osvdb
Reporter Jan Schneider(jan@horde.org)
Modified 2005-04-25T22:35:48

Description

Vulnerability Description

Horde Forwards Module contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate user-supplied input variables upon submission to the parent frame's page title. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

Solution Description

Upgrade to version 2.2.2 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

Short Description

Horde Forwards Module contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate user-supplied input variables upon submission to the parent frame's page title. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

References:

Vendor URL: http://www.horde.org/forwards/ Vendor Specific News/Changelog Entry: http://marc.theaimsgroup.com/?l=horde-announce&m=111464235117679&w=2 Vendor Specific News/Changelog Entry: http://cvs.horde.org/diff.php/forwards/docs/CHANGES?r1=1.1.1.1.2.20&r2=1.1.1.1.2.23&ty=h Vendor Specific Advisory URL Secunia Advisory ID:15082 Keyword: sork ISS X-Force ID: 20235 CVE-2005-1318 Bugtraq ID: 13366