Solaris in.lpd Arbitrary Local Command Execution

2001-08-31T00:00:00
ID OSVDB:15131
Type osvdb
Reporter ron1n(shellcode@hotmail.com)
Modified 2001-08-31T00:00:00

Description

Vulnerability Description

Solaris contains a flaw that may allow a malicious user to execute arbitrary commands. The issue is triggered when a specially crafted request is sent to the LPD daemon. It is possible that the flaw may allow arbitrary command execution resulting in a loss of integrity.

Solution Description

Currently, there are no known upgrades, patches, or workarounds available to correct this issue.

Short Description

Solaris contains a flaw that may allow a malicious user to execute arbitrary commands. The issue is triggered when a specially crafted request is sent to the LPD daemon. It is possible that the flaw may allow arbitrary command execution resulting in a loss of integrity.

References:

Mail List Post: http://archives.neohapsis.com/archives/bugtraq/2001-08/0429.html ISS X-Force ID: 7087 Generic Exploit URL: http://metasploit.com/projects/Framework/modules/exploits/solaris_lpd_exec.pm Bugtraq ID: 3274