Midnight Commander Multiple Unspecified Overflows

2005-01-14T09:10:59
ID OSVDB:12903
Type osvdb
Reporter OSVDB
Modified 2005-01-14T09:10:59

Description

Vulnerability Description

Midnight Commander contains multiple overflow flaws that may allow an attacker to execute arbitrary code. No further details have been provided.

Solution Description

Debian has issued an update. Upgrade to version mc_4.5.55-1.2woody5 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

Short Description

Midnight Commander contains multiple overflow flaws that may allow an attacker to execute arbitrary code. No further details have been provided.

References:

Vendor URL: http://www.ibiblio.org/mc/ Vendor Specific Advisory URL Security Tracker: 1012903 Secunia Advisory ID:13859 Secunia Advisory ID:13863 Secunia Advisory ID:14331 Related OSVDB ID: 12907 Related OSVDB ID: 12911 Related OSVDB ID: 12904 Related OSVDB ID: 12905 Related OSVDB ID: 12906 Related OSVDB ID: 12902 Related OSVDB ID: 12908 Related OSVDB ID: 12909 Related OSVDB ID: 12910 Other Advisory URL: http://security.gentoo.org/glsa/glsa-200502-24.xml Other Advisory URL: http://www.debian.org/security/2005/dsa-639 CVE-2004-1005