phpCodeGenie PCG Simple Application Customer Header/Footer Arbitrary Code Execution

2004-10-23T06:23:58
ID OSVDB:11102
Type osvdb
Reporter OSVDB
Modified 2004-10-23T06:23:58

Description

Vulnerability Description

phpCodeGenie (PCG) contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate variables upon submission to the header and footer textbox. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

Solution Description

Upgrade to version 3.0.3 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

Short Description

phpCodeGenie (PCG) contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate variables upon submission to the header and footer textbox. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

References:

Vendor URL: http://phpcodegenie.sourceforge.net/ Vendor Specific News/Changelog Entry: http://phpcodegenie.sourceforge.net/phpCodeGenie/docs/ChangeLog.txt Security Tracker: 1011911 Secunia Advisory ID:12853