Gnofract 4D .fct File Arbitrary Python Code Execution

2004-10-16T03:20:34
ID OSVDB:10853
Type osvdb
Reporter OSVDB
Modified 2004-10-16T03:20:34

Description

Vulnerability Description

Gnofract 4d contains a flaw related to a .fct file that may allow an attacker to insert and execute arbitrary Python code. No further details have been provided.

Solution Description

Upgrade to version 2.2 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

Short Description

Gnofract 4d contains a flaw related to a .fct file that may allow an attacker to insert and execute arbitrary Python code. No further details have been provided.

References:

Vendor URL: http://gnofract4d.sourceforge.net/ Vendor Specific News/Changelog Entry: http://sourceforge.net/project/shownotes.php?group_id=785&release_id=275738 Security Tracker: 1011757 Secunia Advisory ID:12855 Mail List Post: http://archives.neohapsis.com/archives/apps/freshmeat/2004-10/0016.html