Lucene search

K
osvGoogleOSV:USN-5321-2
HistoryMar 17, 2022 - 12:47 p.m.

firefox vulnerabilities

2022-03-1712:47:30
Google
osv.dev
5
usn-5321-1
firefox
security vulnerabilities
arm64
yandex
mail.ru
denial of service
browser ui
security restrictions
sensitive information
arbitrary code
toctou bug
addon signatures

AI Score

10

Confidence

High

EPSS

0.004

Percentile

74.8%

USN-5321-1 fixed vulnerabilities in Firefox. The update didn’t include
arm64 because of a regression. This update provides the corresponding
update for arm64.

This update also removes Yandex and Mail.ru as optional search providers
in the drop-down search menu.

Original advisory details:

Multiple security issues were discovered in Firefox. If a user were
tricked into opening a specially crafted website, an attacker could
potentially exploit these to cause a denial of service, spoof the browser
UI, bypass security restrictions, obtain sensitive information, or execute
arbitrary code. (CVE-2022-0843, CVE-2022-26381, CVE-2022-26382,
CVE-2022-26383, CVE-2022-26384, CVE-2022-26385)

A TOCTOU bug was discovered when verifying addon signatures during
install. A local attacker could potentially exploit this to trick a
user into installing an addon with an invalid signature.
(CVE-2022-26387)