logo
DATABASE RESOURCES PRICING ABOUT US

PYSEC-2020-4

Description

A flaw was found in the Ansible Engine when using module_args. Tasks executed with check mode (--check-mode) do not properly neutralize sensitive data exposed in the event data. This flaw allows unauthorized users to read this data. The highest threat from this vulnerability is to confidentiality.


Affected Software


CPE Name Name Version
ansible 2.8.0
ansible 2.8.1
ansible 2.8.2
ansible 2.8.3
ansible 2.8.4
ansible 2.8.5
ansible 2.8.6
ansible 2.8.7
ansible 2.8.8
ansible 2.8.9
ansible 2.8.10
ansible 2.8.11
ansible 2.8.12
ansible 2.8.13
ansible 2.9.0
ansible 2.9.1
ansible 2.9.2
ansible 2.9.3
ansible 2.9.4
ansible 2.9.5
ansible 2.9.6
ansible 2.9.7
ansible 2.9.8
ansible 2.9.9
ansible 2.9.10
ansible 2.9.11

Related