Lucene search

K
osvGoogleOSV:MAL-2023-614
HistoryJul 16, 2023 - 12:17 a.m.

Malicious code in n-messaging-client (npm)

2023-07-1600:17:05
Google
osv.dev
2
malicious behavior
package compromise
key rotation

7.2 High

AI Score

Confidence

Low


-= Per source details. Do not edit below this line.=-

Source: ghsa-malware (9a7dbe95def0d204c9533eba028f108451dd6ce16866266114b1cf2cd1cfb4c7)

Any computer that has this package installed or running should be considered fully compromised. All secrets and keys stored on that computer should be rotated immediately from a different computer. The package should be removed, but as full control of the computer may have been given to an outside entity, there is no guarantee that removing the package will remove all malicious software resulting from installing it.

Source: ossf-package-analysis (cb370dee287024ec942a135fdc9300823654874540cb7caf5252145263739865)

The OpenSSF Package Analysis project identified β€˜n-messaging-client’ @ 1.999.0 (npm) as malicious.

It is considered malicious because:

  • The package executes one or more commands associated with malicious behavior.

7.2 High

AI Score

Confidence

Low