Lucene search

K
osvGoogleOSV:GHSA-R9CH-M4FH-FC7Q
HistoryOct 17, 2018 - 4:24 p.m.

Moderate severity vulnerability that affects org.bouncycastle:bcprov-jdk14 and org.bouncycastle:bcprov-jdk15

2018-10-1716:24:00
Google
osv.dev
14

0.004 Low

EPSS

Percentile

73.1%

In the Bouncy Castle JCE Provider version 1.55 and earlier DSA signature generation is vulnerable to timing attack. Where timings can be closely observed for the generation of signatures, the lack of blinding in 1.55, or earlier, may allow an attacker to gain information about the signature’s k value and ultimately the private value as well.