logo
DATABASE RESOURCES PRICING ABOUT US

Denial of Service in i18n

Description

This affects the package i18n before version 2.1.15. Vulnerability arises out of insufficient handling of erroneous language tags in src/i18n/Concrete/TextLocalizer.cs and src/i18n/LocalizedApplication.cs.


Affected Software


CPE Name Name Version
i18n 1.0.0
i18n 1.0.1
i18n 1.0.2
i18n 1.0.3
i18n 1.0.4
i18n 1.0.5
i18n 1.0.5-candidate
i18n 1.0.6
i18n 1.0.7
i18n 1.0.8
i18n 2.1.0
i18n 2.1.1
i18n 2.1.10
i18n 2.1.10-pre000
i18n 2.1.10-pre005
i18n 2.1.10-pre006
i18n 2.1.10-pre011
i18n 2.1.11
i18n 2.1.11-pre000
i18n 2.1.11-pre001
i18n 2.1.11-pre002
i18n 2.1.12-pre001
i18n 2.1.13
i18n 2.1.14
i18n 2.1.15-pre000
i18n 2.1.3
i18n 2.1.4
i18n 2.1.5
i18n 2.1.6
i18n 2.1.7
i18n 2.1.8
i18n 2.1.9

Related