Lucene search

K
osvGoogleOSV:GHSA-86F3-HF24-76Q4
HistoryFeb 22, 2022 - 7:40 p.m.

Use of Hard-coded Cryptographic Key in Netmaker

2022-02-2219:40:23
Google
osv.dev
15

0.001 Low

EPSS

Percentile

46.3%

Impact

There is a hard-coded cryptographic key in the code base which can be exploited to run admin commands on a remote server, if you know the address and username of the admin. This effects the server (netmaker) component, and not clients.

Patches

This has been patched in Netmaker v0.8.5, v0.9.4, and v0.10.0. If you are running these versions, the fix is to perform the following:

  1. docker-compose down
  2. docker pull gravitl/netmaker:( version )
  3. docker-compose up -d

Additional Information

If you are running any other version, you will need to upgrade to one of these three versions. If you have a special circumstance that requires running a different version, let us know and we may be able to build a custom patch.

For more information

If you have any questions or comments about this advisory:

0.001 Low

EPSS

Percentile

46.3%

Related for OSV:GHSA-86F3-HF24-76Q4