logo
DATABASE RESOURCES PRICING ABOUT US

imagemagick - security update

Description

Bob Friesenhahn from the GraphicsMagick project discovered a command injection vulnerability in ImageMagick, a program suite for image manipulation. An attacker with control on input image or the input filename can execute arbitrary commands with the privileges of the user running the application. This update removes the possibility of using pipe (|) in filenames to interact with imagemagick. It is important that you upgrade the libmagickcore5 and not just the imagemagick package. Applications using libmagickcore5 might also be affected and need to be restarted after the upgrade. For Debian 7 Wheezy, these problems have been fixed in version 8:6.7.7.10-5+deb7u6. We recommend that you upgrade your imagemagick packages. Further information about Debian LTS security advisories, how to apply these updates to your system and frequently asked questions can be found at: <https://wiki.debian.org/LTS>


Affected Software


CPE Name Name Version
imagemagick 8:6.7.7.10-5
imagemagick 8:6.7.7.10-5+deb7u2
imagemagick 8:6.7.7.10-5+deb7u3
imagemagick 8:6.7.7.10-5+deb7u4
imagemagick 8:6.7.7.10-5+deb7u5

Related