logo
DATABASE RESOURCES PRICING ABOUT US

CVE-2021-44790

Description

A carefully crafted request body can cause a buffer overflow in the mod_lua multipart parser (r:parsebody() called from Lua scripts). The Apache httpd team is not aware of an exploit for the vulnerabilty though it might be possible to craft one. This issue affects Apache HTTP Server 2.4.51 and earlier.


Affected Software


CPE Name Name Version
apache2 2.2.16
apache2 2.2.17
apache2 2.2.20
apache2 2.2.21
apache2 2.2.22
apache2 2.4.10
apache2 2.4.12
apache2 2.4.16
apache2 2.4.17
apache2 2.4.18
apache2 2.4.20
apache2 2.4.23
apache2 2.4.25
apache2 2.4.26
apache2 2.4.27
apache2 2.4.28
apache2 2.4.29
apache2 2.4.3
apache2 2.4.33
apache2 2.4.34
apache2 2.4.35
apache2 2.4.37
apache2 2.4.38
apache2 2.4.39
apache2 2.4.4
apache2 2.4.41
apache2 2.4.43
apache2 2.4.46
apache2 2.4.48
apache2 2.4.49
apache2 2.4.50
apache2 2.4.51
apache2 2.4.6
apache2 2.4.7
apache2 2.4.9

Related