Lucene search

K
osvGoogleOSV:BIT-PHP-2020-7059
HistoryMar 06, 2024 - 11:07 a.m.

BIT-php-2020-7059

2024-03-0611:07:56
Google
osv.dev
8
php
fgetss() function
information disclosure
buffer overflow

6.2 Medium

AI Score

Confidence

Low

0.004 Low

EPSS

Percentile

73.9%

When using fgetss() function to read data with stripping tags, in PHP versions 7.2.x below 7.2.27, 7.3.x below 7.3.14 and 7.4.x below 7.4.2 it is possible to supply data that will cause this function to read past the allocated buffer. This may lead to information disclosure or crash.

CPENameOperatorVersion
phpge7.4.0
phplt7.4.2
phplt7.3.14
phpge7.2.0
phplt7.2.27
phpge7.3.0