java-1.8.0-openjdk security and bug fix update

2019-04-17T00:00:00
ID ELSA-2019-0774
Type oraclelinux
Reporter Oracle
Modified 2019-04-17T00:00:00

Description

[1:1.8.0.212.b04-1] - Update to aarch64-shenandoah-jdk8u212-b04. - Resolves: rhbz#1693468 [1:1.8.0.212.b03-0] - Update to aarch64-shenandoah-jdk8u212-b03. - Resolves: rhbz#1693468 [1:1.8.0.212.b02-0] - Update to aarch64-shenandoah-jdk8u212-b02. - Remove patches included upstream - JDK-8197429/PR3546/RH153662{2,3} - JDK-8184309/PR3596 - Re-generate patches - JDK-8203030 - Add casts to resolve s390 ambiguity in calls to log2_intptr - Resolves: rhbz#1693468 [1:1.8.0.202.b08-0] - Update to aarch64-shenandoah-jdk8u202-b08. - Remove patches included upstream - JDK-8211387/PR3559 - JDK-8073139/PR1758/RH1191652 - JDK-8044235 - JDK-8131048/PR3574/RH1498936 - JDK-8164920/PR3574/RH1498936 - Resolves: rhbz#1693468 [1:1.8.0.201.b13-0] - Update to aarch64-shenandoah-jdk8u201-b13. - Drop JDK-8160748 & JDK-8189170 AArch64 patches now applied upstream. - Resolves: rhbz#1693468 [1:1.8.0.201.b09-3] - Update patch for RH1566890. - Renamed rh1566890_speculative_store_bypass_so_added_more_per_task_speculation_control_CVE_2018_3639 to rh1566890-CVE_2018_3639-speculative_store_bypass.patch - Added dependent patch, rh1566890-CVE_2018_3639-speculative_store_bypass_toggle.patch - Resolves: rhbz#1693468