Lucene search

K
openvasCopyright (C) 2022 Greenbone AGOPENVAS:1361412562310893230
HistoryDec 08, 2022 - 12:00 a.m.

Debian: Security Advisory (DLA-3230-1)

2022-12-0800:00:00
Copyright (C) 2022 Greenbone AG
plugins.openvas.org
7
debian
jqueryui
security update
multiple vulnerabilities

CVSS2

4.3

Attack Vector

NETWORK

Attack Complexity

MEDIUM

Authentication

NONE

Confidentiality Impact

NONE

Integrity Impact

PARTIAL

Availability Impact

NONE

AV:N/AC:M/Au:N/C:N/I:P/A:N

CVSS3

6.5

Attack Vector

NETWORK

Attack Complexity

LOW

Privileges Required

NONE

User Interaction

REQUIRED

Scope

UNCHANGED

Confidentiality Impact

NONE

Integrity Impact

HIGH

Availability Impact

NONE

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N

AI Score

7

Confidence

High

EPSS

0.005

Percentile

75.4%

The remote host is missing an update for the Debian

# SPDX-FileCopyrightText: 2022 Greenbone AG
# Some text descriptions might be excerpted from (a) referenced
# source(s), and are Copyright (C) by the respective right holder(s).
#
# SPDX-License-Identifier: GPL-2.0-only

if(description)
{
  script_oid("1.3.6.1.4.1.25623.1.0.893230");
  script_cve_id("CVE-2021-41182", "CVE-2021-41183", "CVE-2021-41184", "CVE-2022-31160");
  script_tag(name:"creation_date", value:"2022-12-08 02:00:13 +0000 (Thu, 08 Dec 2022)");
  script_version("2024-02-02T05:06:08+0000");
  script_tag(name:"last_modification", value:"2024-02-02 05:06:08 +0000 (Fri, 02 Feb 2024)");
  script_tag(name:"cvss_base", value:"4.3");
  script_tag(name:"cvss_base_vector", value:"AV:N/AC:M/Au:N/C:N/I:P/A:N");
  script_tag(name:"severity_vector", value:"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N");
  script_tag(name:"severity_origin", value:"NVD");
  script_tag(name:"severity_date", value:"2022-07-27 14:46:17 +0000 (Wed, 27 Jul 2022)");

  script_name("Debian: Security Advisory (DLA-3230-1)");
  script_category(ACT_GATHER_INFO);
  script_copyright("Copyright (C) 2022 Greenbone AG");
  script_family("Debian Local Security Checks");
  script_dependencies("gather-package-list.nasl");
  script_mandatory_keys("ssh/login/debian_linux", "ssh/login/packages", re:"ssh/login/release=DEB10");

  script_xref(name:"Advisory-ID", value:"DLA-3230-1");
  script_xref(name:"URL", value:"https://www.debian.org/lts/security/2022/DLA-3230-1");
  script_xref(name:"URL", value:"https://security-tracker.debian.org/tracker/jqueryui");
  script_xref(name:"URL", value:"https://wiki.debian.org/LTS");

  script_tag(name:"summary", value:"The remote host is missing an update for the Debian 'jqueryui' package(s) announced via the DLA-3230-1 advisory.");

  script_tag(name:"vuldetect", value:"Checks if a vulnerable package version is present on the target host.");

  script_tag(name:"insight", value:"jQuery-UI, the official jQuery user interface library, is a curated set of user interface interactions, effects, widgets, and themes built on top of jQuery were reported to have the following vulnerabilities.

CVE-2021-41182

jQuery-UI was accepting the value of the `altField` option of the Datepicker widget from untrusted sources may execute untrusted code. This has been fixed and now any string value passed to the `altField` option is now treated as a CSS selector.

CVE-2021-41183

jQuery-UI was accepting the value of various `*Text` options of the Datepicker widget from untrusted sources may execute untrusted code. This has been fixed and now the values passed to various `*Text` options are now always treated as pure text, not HTML.

CVE-2021-41184

jQuery-UI was accepting the value of the `of` option of the `.position()` util from untrusted sources may execute untrusted code. This has been fixed and now any string value passed to the `of` option is now treated as a CSS selector.

CVE-2022-31160

jQuery-UI was potentially vulnerable to cross-site scripting. Initializing a checkboxradio widget on an input enclosed within a label makes that parent label contents considered as the input label. Calling `.checkboxradio( refresh )` on such a widget and the initial HTML contained encoded HTML entities will make them erroneously get decoded. This can lead to potentially executing JavaScript code.

For Debian 10 buster, these problems have been fixed in version 1.12.1+dfsg-5+deb10u1.

We recommend that you upgrade your jqueryui packages.

For the detailed security status of jqueryui please refer to its security tracker page at: [link moved to references]

Further information about Debian LTS security advisories, how to apply these updates to your system and frequently asked questions can be found at: [link moved to references]");

  script_tag(name:"affected", value:"'jqueryui' package(s) on Debian 10.");

  script_tag(name:"solution", value:"Please install the updated package(s).");

  script_tag(name:"solution_type", value:"VendorFix");
  script_tag(name:"qod_type", value:"package");

  exit(0);
}

include("revisions-lib.inc");
include("pkg-lib-deb.inc");

release = dpkg_get_ssh_release();
if(!release)
  exit(0);

res = "";
report = "";

if(release == "DEB10") {

  if(!isnull(res = isdpkgvuln(pkg:"libjs-jquery-ui", ver:"1.12.1+dfsg-5+deb10u1", rls:"DEB10"))) {
    report += res;
  }

  if(!isnull(res = isdpkgvuln(pkg:"libjs-jquery-ui-docs", ver:"1.12.1+dfsg-5+deb10u1", rls:"DEB10"))) {
    report += res;
  }

  if(!isnull(res = isdpkgvuln(pkg:"node-jquery-ui", ver:"1.12.1+dfsg-5+deb10u1", rls:"DEB10"))) {
    report += res;
  }

  if(report != "") {
    security_message(data:report);
  } else if(__pkg_match) {
    exit(99);
  }
  exit(0);
}

exit(0);

CVSS2

4.3

Attack Vector

NETWORK

Attack Complexity

MEDIUM

Authentication

NONE

Confidentiality Impact

NONE

Integrity Impact

PARTIAL

Availability Impact

NONE

AV:N/AC:M/Au:N/C:N/I:P/A:N

CVSS3

6.5

Attack Vector

NETWORK

Attack Complexity

LOW

Privileges Required

NONE

User Interaction

REQUIRED

Scope

UNCHANGED

Confidentiality Impact

NONE

Integrity Impact

HIGH

Availability Impact

NONE

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N

AI Score

7

Confidence

High

EPSS

0.005

Percentile

75.4%