Lucene search

K
openvasCopyright (C) 2013 Greenbone AGOPENVAS:1361412562310865526
HistoryApr 05, 2013 - 12:00 a.m.

Fedora Update for php FEDORA-2013-3891

2013-04-0500:00:00
Copyright (C) 2013 Greenbone AG
plugins.openvas.org
12

6.7 Medium

AI Score

Confidence

Low

0.018 Low

EPSS

Percentile

88.1%

The remote host is missing an update for the

# SPDX-FileCopyrightText: 2013 Greenbone AG
# Some text descriptions might be excerpted from (a) referenced
# source(s), and are Copyright (C) by the respective right holder(s).
#
# SPDX-License-Identifier: GPL-2.0-only

if(description)
{
  script_tag(name:"affected", value:"php on Fedora 18");
  script_tag(name:"solution", value:"Please install the updated package(s).");
  script_oid("1.3.6.1.4.1.25623.1.0.865526");
  script_version("2023-06-22T10:34:15+0000");
  script_tag(name:"last_modification", value:"2023-06-22 10:34:15 +0000 (Thu, 22 Jun 2023)");
  script_tag(name:"creation_date", value:"2013-04-05 13:44:53 +0530 (Fri, 05 Apr 2013)");
  script_cve_id("CVE-2013-1635", "CVE-2013-1643");
  script_tag(name:"cvss_base", value:"7.5");
  script_tag(name:"cvss_base_vector", value:"AV:N/AC:L/Au:N/C:P/I:P/A:P");
  script_tag(name:"qod_type", value:"package");
  script_tag(name:"solution_type", value:"VendorFix");
  script_name("Fedora Update for php FEDORA-2013-3891");
  script_xref(name:"FEDORA", value:"2013-3891");
  script_xref(name:"URL", value:"http://lists.fedoraproject.org/pipermail/package-announce/2013-April/101336.html");
  script_tag(name:"summary", value:"The remote host is missing an update for the 'php'
  package(s) announced via the referenced advisory.");
  script_category(ACT_GATHER_INFO);
  script_copyright("Copyright (C) 2013 Greenbone AG");
  script_family("Fedora Local Security Checks");
  script_dependencies("gather-package-list.nasl");
  script_mandatory_keys("ssh/login/fedora", "ssh/login/rpms", re:"ssh/login/release=FC18");

  exit(0);
}

include("revisions-lib.inc");
include("pkg-lib-rpm.inc");

release = rpm_get_ssh_release();
if(!release)
  exit(0);

res = "";

if(release == "FC18")
{

  if ((res = isrpmvuln(pkg:"php", rpm:"php~5.4.13~1.fc18", rls:"FC18")) != NULL)
  {
    security_message(data:res);
    exit(0);
  }

  if (__pkg_match) exit(99);
  exit(0);
}