Malwarebytes-Anti-Exploit 'Upgrade' Man-In-The-Middle Attack (Windows)

2015-01-02T00:00:00
ID OPENVAS:1361412562310805405
Type openvas
Reporter Copyright (C) 2015 Greenbone Networks GmbH
Modified 2018-10-12T00:00:00

Description

This host is installed with Malwarebytes Anti-Exploit and is prone to man in the middle attack through it

                                        
                                            #######################################################################################
# OpenVAS Vulnerability Test
# $Id: gb_malwarebytes_anti_exploit_upgrade_vuln_win.nasl 11872 2018-10-12 11:22:41Z cfischer $
#
# Malwarebytes-Anti-Exploit 'Upgrade' Man-In-The-Middle Attack (Windows)
#
# Authors:
# Rinu Kuriakose <krinu@secpod.com>
#
# Copyright:
# Copyright (C) 2015 Greenbone Networks GmbH, http://www.greenbone.net
#
# This program is free software; you can redistribute it and/or modify
# it under the terms of the GNU General Public License version 2
# (or any later version), as published by the Free Software Foundation.
#
# This program is distributed in the hope that it will be useful,
# but WITHOUT ANY WARRANTY; without even the implied warranty of
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
# GNU General Public License for more details.
#
# You should have received a copy of the GNU General Public License
# along with this program; if not, write to the Free Software
# Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA.
###############################################################################

CPE = "cpe:/a:malwarebytes:malwarebytes_anti-exploit";

if(description)
{
  script_oid("1.3.6.1.4.1.25623.1.0.805405");
  script_version("$Revision: 11872 $");
  script_cve_id("CVE-2014-4936");
  script_tag(name:"cvss_base", value:"9.3");
  script_tag(name:"cvss_base_vector", value:"AV:N/AC:M/Au:N/C:C/I:C/A:C");
  script_tag(name:"last_modification", value:"$Date: 2018-10-12 13:22:41 +0200 (Fri, 12 Oct 2018) $");
  script_tag(name:"creation_date", value:"2015-01-02 11:26:06 +0530 (Fri, 02 Jan 2015)");
  script_name("Malwarebytes-Anti-Exploit 'Upgrade' Man-In-The-Middle Attack (Windows)");

  script_tag(name:"summary", value:"This host is installed with Malwarebytes
  Anti-Exploit and is prone to man in the middle attack through it's upgrade
  functionality.");

  script_tag(name:"vuldetect", value:"Checks if a vulnerable version is present on the target host.");

  script_tag(name:"insight", value:"MBAE client does not verify the actual
  installer it downloads. This is combined with the fact that MBAE starts the
  new client installer with full administrative privileges.");

  script_tag(name:"impact", value:"Successful exploitation will allow
  remote attackers to execute arbitrary code by spoofing the update server
  and uploading an executable.");

  script_tag(name:"affected", value:"Malwarebytes Anti-Exploit
  (MBAE) Consumer versions prior to 1.04.1.1012 on Windows");

  script_tag(name:"solution", value:"Upgrade to version 1.04.1.1012
  or later.");

  script_tag(name:"solution_type", value:"VendorFix");

  script_xref(name:"URL", value:"https://github.com/0x3a/CVE-2014-4936");
  script_xref(name:"URL", value:"http://blog.0x3a.com/post/104954032239/cve-2014-4936-malwarebytes-anti-malware-and");
  script_category(ACT_GATHER_INFO);
  script_tag(name:"qod_type", value:"registry");
  script_family("General");
  script_copyright("Copyright (C) 2015 Greenbone Networks GmbH");
  script_dependencies("gb_malwarebytes_anti_exploit_detect_win.nasl");
  script_mandatory_keys("Malwarebytes/Anti-Exploit/Win/Installed");
  script_xref(name:"URL", value:"https://www.malwarebytes.org");
  exit(0);
}


include("version_func.inc");
include("host_details.inc");

if(!mbversion = get_app_version(cpe:CPE)){
  exit(0);
}

## This version is considered because the vulnerability is seems to be fixed according to https://github.com/0x3a/CVE-2014-4936
if(version_is_less(version:mbversion, test_version:"1.04.1.1012"))
{
  security_message( port: 0, data: "The target host was found to be vulnerable" );
  exit(0);
}