Lucene search

K
openvasCopyright (C) 2011 Greenbone AGOPENVAS:1361412562310802320
HistoryAug 10, 2011 - 12:00 a.m.

Habari Installation Path Disclosure Vulnerability

2011-08-1000:00:00
Copyright (C) 2011 Greenbone AG
plugins.openvas.org
8

7.2 High

AI Score

Confidence

Low

Habari is prone to path disclosure vulnerability.

# SPDX-FileCopyrightText: 2011 Greenbone AG
# Some text descriptions might be excerpted from (a) referenced
# source(s), and are Copyright (C) by the respective right holder(s).
#
# SPDX-License-Identifier: GPL-2.0-only

if(description)
{
  script_oid("1.3.6.1.4.1.25623.1.0.802320");
  script_version("2023-12-13T05:05:23+0000");
  script_tag(name:"last_modification", value:"2023-12-13 05:05:23 +0000 (Wed, 13 Dec 2023)");
  script_tag(name:"creation_date", value:"2011-08-10 13:49:51 +0200 (Wed, 10 Aug 2011)");
  script_tag(name:"cvss_base", value:"4.3");
  script_tag(name:"cvss_base_vector", value:"AV:N/AC:M/Au:N/C:N/I:P/A:N");
  script_name("Habari Installation Path Disclosure Vulnerability");
  script_xref(name:"URL", value:"http://secpod.org/blog/?p=265");
  script_xref(name:"URL", value:"http://secpod.org/advisories/SECPOD_Habari_Info_Disc_Vuln.txt");

  script_category(ACT_ATTACK);
  script_copyright("Copyright (C) 2011 Greenbone AG");
  script_family("Web application abuses");
  script_dependencies("find_service.nasl", "no404.nasl", "webmirror.nasl", "DDI_Directory_Scanner.nasl", "gb_php_http_detect.nasl", "global_settings.nasl");
  script_require_ports("Services/www", 80);
  script_exclude_keys("Settings/disable_cgi_scanning");

  script_tag(name:"impact", value:"Successful exploitation will allow attacker to gain sensitive
  information like installation path location.");

  script_tag(name:"affected", value:"Habari 0.7.1 and prior.");

  script_tag(name:"insight", value:"The flaw is caused by improper validation of certain user-supplied
  input passed, which allows attacker to gain sensitive information.");

  script_tag(name:"solution", value:"No known solution was made available for at least one year since the disclosure
  of this vulnerability. Likely none will be provided anymore. General solution options are to upgrade to a newer
  release, disable respective features, remove the product or replace the product by another one.");

  script_tag(name:"summary", value:"Habari is prone to path disclosure vulnerability.");

  script_tag(name:"solution_type", value:"WillNotFix");
  script_tag(name:"qod_type", value:"remote_app");
  exit(0);
}

include("http_func.inc");
include("http_keepalive.inc");
include("port_service_func.inc");
include("list_array_func.inc");

port = http_get_port(default:80);

if(!http_can_host_php(port:port)) {
  exit(0);
}

foreach dir(make_list_unique("/habari", "/myhabari", http_cgi_dirs(port:port)))
{

  if(dir == "/") dir = "";

  res = http_get_cache(item: dir + "/", port:port);

  if("<title>My Habari</title>" >< res)
  {
    url = dir + "/config.php";
    req = http_get(item:url, port:port);
    res = http_keepalive_send_recv(port:port, data:req);

    if(egrep(pattern:"<b>Fatal error</b>:  Class 'Config' not found in.*\c" +
                     "onfig.php", string:res))
    {
      report = http_report_vuln_url(port:port, url:url);
      security_message(port:port, data:report);
      exit(0);
    }
  }
}

exit(99);

7.2 High

AI Score

Confidence

Low