Lucene search

K
openvasCopyright (C) 2011 Greenbone AGOPENVAS:1361412562310801845
HistoryFeb 15, 2011 - 12:00 a.m.

Adobe Reader Multiple Vulnerabilities (Feb 2011) - Linux

2011-02-1500:00:00
Copyright (C) 2011 Greenbone AG
plugins.openvas.org
17

CVSS2

9.3

Attack Vector

NETWORK

Attack Complexity

MEDIUM

Authentication

NONE

Confidentiality Impact

COMPLETE

Integrity Impact

COMPLETE

Availability Impact

COMPLETE

AV:N/AC:M/Au:N/C:C/I:C/A:C

AI Score

9

Confidence

High

EPSS

0.846

Percentile

98.5%

Adobe Reader is prone to multiple vulnerabilities.

# SPDX-FileCopyrightText: 2011 Greenbone AG
# Some text descriptions might be excerpted from (a) referenced
# source(s), and are Copyright (C) by the respective right holder(s).
#
# SPDX-License-Identifier: GPL-2.0-only
CPE = "cpe:/a:adobe:acrobat_reader";

if(description)
{
  script_oid("1.3.6.1.4.1.25623.1.0.801845");
  script_version("2024-02-20T14:37:13+0000");
  script_cve_id("CVE-2010-4091", "CVE-2011-0562", "CVE-2011-0563",
                "CVE-2011-0564", "CVE-2011-0565", "CVE-2011-0566",
                "CVE-2011-0567", "CVE-2011-0568", "CVE-2011-0570",
                "CVE-2011-0585", "CVE-2011-0586", "CVE-2011-0587",
                "CVE-2011-0588", "CVE-2011-0589", "CVE-2011-0590",
                "CVE-2011-0591", "CVE-2011-0592", "CVE-2011-0593",
                "CVE-2011-0594", "CVE-2011-0595", "CVE-2011-0596",
                "CVE-2011-0598", "CVE-2011-0599", "CVE-2011-0600",
                "CVE-2011-0602", "CVE-2011-0603", "CVE-2011-0604",
                "CVE-2011-0605", "CVE-2011-0606");
  script_tag(name:"cvss_base", value:"9.3");
  script_tag(name:"cvss_base_vector", value:"AV:N/AC:M/Au:N/C:C/I:C/A:C");
  script_tag(name:"last_modification", value:"2024-02-20 14:37:13 +0000 (Tue, 20 Feb 2024)");
  script_tag(name:"creation_date", value:"2011-02-15 08:14:35 +0100 (Tue, 15 Feb 2011)");
  script_name("Adobe Reader Multiple Vulnerabilities (Feb 2011) - Linux");


  script_tag(name:"summary", value:"Adobe Reader is prone to multiple vulnerabilities.");
  script_tag(name:"vuldetect", value:"Checks if a vulnerable version is present on the target host.");
  script_tag(name:"insight", value:"Multiple flaws are present in Adobe Reader due to insecure permissions, input
validation errors, memory corruptions, and buffer overflow errors when
processing malformed contents within a PDF document.");
  script_tag(name:"impact", value:"Successful exploitation will let local attackers to obtain elevated
privileges, or by remote attackers to inject scripting code, or execute
arbitrary commands by tricking a user into opening a malicious PDF document.");
  script_tag(name:"affected", value:"Adobe Reader 9.4.1 and earlier versions for Linux.");
  script_tag(name:"solution", value:"Upgrade to Adobe Reader version 9.4.2 or later.");
  script_tag(name:"qod_type", value:"executable_version");
  script_tag(name:"solution_type", value:"VendorFix");

  script_xref(name:"URL", value:"http://www.vupen.com/english/advisories/2011/0337");
  script_xref(name:"URL", value:"http://www.securityfocus.com/bid/46146");
  script_xref(name:"URL", value:"http://www.adobe.com/support/security/bulletins/apsb11-03.html");
  script_category(ACT_GATHER_INFO);
  script_copyright("Copyright (C) 2011 Greenbone AG");
  script_family("General");
  script_dependencies("gb_adobe_prdts_detect_lin.nasl");
  script_mandatory_keys("Adobe/Reader/Linux/Version");
  exit(0);
}


include("host_details.inc");
include("version_func.inc");


if(!readerVer = get_app_version(cpe:CPE)){
  exit(0);
}

if(version_is_less(version:readerVer, test_version:"9.4.2"))
{
  report = report_fixed_ver(installed_version:readerVer, fixed_version:"9.4.2");
  security_message(port: 0, data: report);
  exit(0);
}

CVSS2

9.3

Attack Vector

NETWORK

Attack Complexity

MEDIUM

Authentication

NONE

Confidentiality Impact

COMPLETE

Integrity Impact

COMPLETE

Availability Impact

COMPLETE

AV:N/AC:M/Au:N/C:C/I:C/A:C

AI Score

9

Confidence

High

EPSS

0.846

Percentile

98.5%