Lucene search

K
openvasCopyright (C) 2012 E-Soft Inc.OPENVAS:136141256231071585
HistoryAug 10, 2012 - 12:00 a.m.

Gentoo Security Advisory GLSA 201206-18 (GnuTLS)

2012-08-1000:00:00
Copyright (C) 2012 E-Soft Inc.
plugins.openvas.org
15

6.7 Medium

AI Score

Confidence

Low

7.5 High

CVSS2

Access Vector

Access Complexity

Authentication

NONE

Confidentiality Impact

PARTIAL

Integrity Impact

PARTIAL

Availability Impact

PARTIAL

AV:N/AC:L/Au:N/C:P/I:P/A:P

0.956 High

EPSS

Percentile

99.4%

The remote host is missing updates announced in
advisory GLSA 201206-18.

# SPDX-FileCopyrightText: 2012 E-Soft Inc.
# Some text descriptions might be excerpted from (a) referenced
# source(s), and are Copyright (C) by the respective right holder(s).
#
# SPDX-License-Identifier: GPL-2.0-only OR GPL-3.0-only

if(description)
{
  script_oid("1.3.6.1.4.1.25623.1.0.71585");
  script_tag(name:"cvss_base", value:"7.5");
  script_tag(name:"cvss_base_vector", value:"AV:N/AC:L/Au:N/C:P/I:P/A:P");
  script_cve_id("CVE-2009-2730", "CVE-2009-3555", "CVE-2011-4128", "CVE-2012-1573");
  script_version("2023-07-14T16:09:26+0000");
  script_tag(name:"last_modification", value:"2023-07-14 16:09:26 +0000 (Fri, 14 Jul 2023)");
  script_tag(name:"creation_date", value:"2012-08-10 03:22:56 -0400 (Fri, 10 Aug 2012)");
  script_name("Gentoo Security Advisory GLSA 201206-18 (GnuTLS)");
  script_category(ACT_GATHER_INFO);
  script_copyright("Copyright (C) 2012 E-Soft Inc.");
  script_family("Gentoo Local Security Checks");
  script_dependencies("gather-package-list.nasl");
  script_mandatory_keys("ssh/login/gentoo", "ssh/login/pkg");
  script_tag(name:"insight", value:"Multiple vulnerabilities have been found in GnuTLS, allowing a
remote attacker to perform man-in-the-middle or Denial of Service
attacks.");
  script_tag(name:"solution", value:"All GnuTLS users should upgrade to the latest version:

      # emerge --sync
      # emerge --ask --oneshot --verbose '>=net-libs/gnutls-2.12.18'");

  script_xref(name:"URL", value:"http://www.securityspace.com/smysecure/catid.html?in=GLSA%20201206-18");
  script_xref(name:"URL", value:"http://bugs.gentoo.org/show_bug.cgi?id=281224");
  script_xref(name:"URL", value:"http://bugs.gentoo.org/show_bug.cgi?id=292025");
  script_xref(name:"URL", value:"http://bugs.gentoo.org/show_bug.cgi?id=389947");
  script_xref(name:"URL", value:"http://bugs.gentoo.org/show_bug.cgi?id=409287");
  script_tag(name:"summary", value:"The remote host is missing updates announced in
advisory GLSA 201206-18.");
  script_tag(name:"qod_type", value:"package");
  script_tag(name:"solution_type", value:"VendorFix");

  exit(0);
}

include("pkg-lib-gentoo.inc");
include("revisions-lib.inc");

res = "";
report = "";
if((res = ispkgvuln(pkg:"net-libs/gnutls", unaffected: make_list("ge 2.12.18"), vulnerable: make_list("lt 2.12.18"))) != NULL ) {
    report += res;
}

if(report != "") {
    security_message(data:report);
} else if (__pkg_match) {
    exit(99);
}

6.7 Medium

AI Score

Confidence

Low

7.5 High

CVSS2

Access Vector

Access Complexity

Authentication

NONE

Confidentiality Impact

PARTIAL

Integrity Impact

PARTIAL

Availability Impact

PARTIAL

AV:N/AC:L/Au:N/C:P/I:P/A:P

0.956 High

EPSS

Percentile

99.4%