Lucene search

K
openvasCopyright (C) 2018 Greenbone AGOPENVAS:1361412562310704147
HistoryMar 20, 2018 - 12:00 a.m.

Debian: Security Advisory (DSA-4147-1)

2018-03-2000:00:00
Copyright (C) 2018 Greenbone AG
plugins.openvas.org
35

9.6 High

AI Score

Confidence

High

0.069 Low

EPSS

Percentile

93.9%

The remote host is missing an update for the Debian

# SPDX-FileCopyrightText: 2018 Greenbone AG
# Some text descriptions might be excerpted from (a) referenced
# source(s), and are Copyright (C) by the respective right holder(s).
#
# SPDX-License-Identifier: GPL-2.0-only

if(description)
{
  script_oid("1.3.6.1.4.1.25623.1.0.704147");
  script_cve_id("CVE-2017-18187", "CVE-2018-0487", "CVE-2018-0488");
  script_tag(name:"creation_date", value:"2018-03-20 23:00:00 +0000 (Tue, 20 Mar 2018)");
  script_version("2024-02-02T05:06:06+0000");
  script_tag(name:"last_modification", value:"2024-02-02 05:06:06 +0000 (Fri, 02 Feb 2024)");
  script_tag(name:"cvss_base", value:"7.5");
  script_tag(name:"cvss_base_vector", value:"AV:N/AC:L/Au:N/C:P/I:P/A:P");
  script_tag(name:"severity_vector", value:"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H");
  script_tag(name:"severity_origin", value:"NVD");
  script_tag(name:"severity_date", value:"2018-03-16 13:53:10 +0000 (Fri, 16 Mar 2018)");

  script_name("Debian: Security Advisory (DSA-4147-1)");
  script_category(ACT_GATHER_INFO);
  script_copyright("Copyright (C) 2018 Greenbone AG");
  script_family("Debian Local Security Checks");
  script_dependencies("gather-package-list.nasl");
  script_mandatory_keys("ssh/login/debian_linux", "ssh/login/packages", re:"ssh/login/release=DEB8");

  script_xref(name:"Advisory-ID", value:"DSA-4147-1");
  script_xref(name:"URL", value:"https://www.debian.org/security/2018/DSA-4147-1");
  script_xref(name:"URL", value:"https://security-tracker.debian.org/tracker/DSA-4147");
  script_xref(name:"URL", value:"https://security-tracker.debian.org/tracker/polarssl");

  script_tag(name:"summary", value:"The remote host is missing an update for the Debian 'polarssl' package(s) announced via the DSA-4147-1 advisory.");

  script_tag(name:"vuldetect", value:"Checks if a vulnerable package version is present on the target host.");

  script_tag(name:"insight", value:"Several vulnerabilities were discovered in PolarSSL, a lightweight crypto and SSL/TLS library, that allowed a remote attacker to either cause a denial-of-service by application crash, or execute arbitrary code.

For the oldstable distribution (jessie), these problems have been fixed in version 1.3.9-2.1+deb8u3.

We recommend that you upgrade your polarssl packages.

For the detailed security status of polarssl please refer to its security tracker page at: [link moved to references]");

  script_tag(name:"affected", value:"'polarssl' package(s) on Debian 8.");

  script_tag(name:"solution", value:"Please install the updated package(s).");

  script_tag(name:"solution_type", value:"VendorFix");
  script_tag(name:"qod_type", value:"package");

  exit(0);
}

include("revisions-lib.inc");
include("pkg-lib-deb.inc");

release = dpkg_get_ssh_release();
if(!release)
  exit(0);

res = "";
report = "";

if(release == "DEB8") {

  if(!isnull(res = isdpkgvuln(pkg:"libpolarssl-dev", ver:"1.3.9-2.1+deb8u3", rls:"DEB8"))) {
    report += res;
  }

  if(!isnull(res = isdpkgvuln(pkg:"libpolarssl-runtime", ver:"1.3.9-2.1+deb8u3", rls:"DEB8"))) {
    report += res;
  }

  if(!isnull(res = isdpkgvuln(pkg:"libpolarssl7", ver:"1.3.9-2.1+deb8u3", rls:"DEB8"))) {
    report += res;
  }

  if(report != "") {
    security_message(data:report);
  } else if(__pkg_match) {
    exit(99);
  }
  exit(0);
}

exit(0);

9.6 High

AI Score

Confidence

High

0.069 Low

EPSS

Percentile

93.9%