EMC Isilon OneFS LDAP Injection Vulnerability

2017-02-08T00:00:00
ID OPENVAS:1361412562310106578
Type openvas
Reporter This script is Copyright (C) 2017 Greenbone Networks GmbH
Modified 2017-03-31T00:00:00

Description

EMC Isilon OneFS is affected by an LDAP injection vulnerability that could potentially be exploited by a malicious user to compromise the system.

                                        
                                            ##############################################################################
# OpenVAS Vulnerability Test
# $Id: gb_emc_isilon_onefs_ldap_inj_vuln.nasl 5823 2017-03-31 13:57:56Z mime $
#
# EMC Isilon OneFS LDAP Injection Vulnerability
#
# Authors:
# Christian Kuersteiner <christian.kuersteiner@greenbone.net>
#
# Copyright:
# Copyright (c) 2017 Greenbone Networks GmbH
#
# This program is free software; you can redistribute it and/or
# modify it under the terms of the GNU General Public License
# as published by the Free Software Foundation; either version 2
# of the License, or (at your option) any later version
#
# This program is distributed in the hope that it will be useful,
# but WITHOUT ANY WARRANTY; without even the implied warranty of
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
# GNU General Public License for more details.
#
# You should have received a copy of the GNU General Public License
# along with this program; if not, write to the Free Software
# Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA.
###############################################################################

CPE = "cpe:/o:emc:isilon_onefs";

if (description)
{
  script_oid("1.3.6.1.4.1.25623.1.0.106578");
  script_version("$Revision: 5823 $");
  script_tag(name: "last_modification", value: "$Date: 2017-03-31 15:57:56 +0200 (Fri, 31 Mar 2017) $");
  script_tag(name: "creation_date", value: "2017-02-08 14:38:14 +0700 (Wed, 08 Feb 2017)");
  script_tag(name: "cvss_base", value: "7.2");
  script_tag(name: "cvss_base_vector", value: "AV:L/AC:L/Au:N/C:C/I:C/A:C");

  script_cve_id("CVE-2016-9870");

  script_tag(name: "qod_type", value: "remote_banner");

  script_tag(name: "solution_type", value: "VendorFix");

  script_name("EMC Isilon OneFS LDAP Injection Vulnerability");

  script_category(ACT_GATHER_INFO);

  script_copyright("This script is Copyright (C) 2017 Greenbone Networks GmbH");
  script_family("General");
  script_dependencies("gb_emc_isilon_onefs_snmp_detect.nasl", "gb_emc_isilon_onefs_ftp_detect.nasl","gb_emc_isilon_onefs_ntp_detect.nasl");
  script_mandatory_keys("emc_isilon_onefs/detected");

  script_tag(name: "summary", value: "EMC Isilon OneFS is affected by an LDAP injection vulnerability that could
potentially be exploited by a malicious user to compromise the system.");

  script_tag(name: "vuldetect", value: "Checks the version.");

  script_tag(name: "insight", value: "A malicious high-privileged local user may leverage the LDAP injection
vulnerability by injecting an asterisk into a username in LDAP searches, which may enable the attacker to
impersonate other users on the system.");

  script_tag(name: "affected", value: "EMC Isilon OneFS 7.1.0.x, 7.1.1.0 - 7.1.1.10, 7.2.0.x, 7.2.1.0 - 7.2.1.2
and 8.0.0.0.");

  script_tag(name: "solution", value: "Update 7.1.1.11, 7.2.1.3, 8.0.0.1 or later versions.");

  script_xref(name: "URL", value: "http://seclists.org/bugtraq/2017/Jan/87");

  exit(0);
}

include("host_details.inc");
include("version_func.inc");

if (!version = get_app_version(cpe: CPE, nofork: TRUE))
  exit(0);

if (version_is_less(version: version, test_version: "7.1.0.0"))
  exit(99);

if (version_is_less(version: version, test_version: "7.1.1.11")) {
  report = report_fixed_ver(installed_version: version, fixed_version: "7.1.1.11");
  security_message(port: 0, data: report);
  exit(0);
}

if (version_in_range(version: version, test_version: "7.2.0.0", test_version2: "7.2.1.2")) {
  report = report_fixed_ver(installed_version: version, fixed_version: "7.2.1.3");
  security_message(port: 0, data: report);
  exit(0);
}

if (version == "8.0.0.0") {
  report = report_fixed_ver(installed_version: version, fixed_version: "8.0.0.1");
  security_message(port: 0, data: report);
  exit(0);
}

exit(0);