Easy Hosting Control Panel FTP Account Security Bypass Vulnerability

2011-10-05T00:00:00
ID OPENVAS:1361412562310103286
Type openvas
Reporter This script is Copyright (C) 2011 Greenbone Networks GmbH
Modified 2018-10-20T00:00:00

Description

Easy Hosting Control Panel is prone to a security-bypass vulnerability.

Attackers could exploit the issue to add arbitrary FTP accounts to the affected application.

Easy Hosting Control Panel versions 0.29.10 up to and including 0.29.13 are vulnerable.

                                        
                                            ###############################################################################
# OpenVAS Vulnerability Test
# $Id: gb_easy_hosting_49937.nasl 11997 2018-10-20 11:59:41Z mmartin $
#
# Easy Hosting Control Panel FTP Account Security Bypass Vulnerability
#
# Authors:
# Michael Meyer <michael.meyer@greenbone.net>
#
# Copyright:
# Copyright (c) 2011 Greenbone Networks GmbH
#
# This program is free software; you can redistribute it and/or modify
# it under the terms of the GNU General Public License version 2
# (or any later version), as published by the Free Software Foundation.
#
# This program is distributed in the hope that it will be useful,
# but WITHOUT ANY WARRANTY; without even the implied warranty of
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
# GNU General Public License for more details.
#
# You should have received a copy of the GNU General Public License
# along with this program; if not, write to the Free Software
# Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA.
###############################################################################

if(description)
{
  script_oid("1.3.6.1.4.1.25623.1.0.103286");
  script_version("$Revision: 11997 $");
  script_tag(name:"last_modification", value:"$Date: 2018-10-20 13:59:41 +0200 (Sat, 20 Oct 2018) $");
  script_tag(name:"creation_date", value:"2011-10-05 13:15:09 +0200 (Wed, 05 Oct 2011)");
  script_bugtraq_id(49937);
  script_tag(name:"cvss_base", value:"7.5");
  script_tag(name:"cvss_base_vector", value:"AV:N/AC:L/Au:N/C:P/I:P/A:P");

  script_name("Easy Hosting Control Panel FTP Account Security Bypass Vulnerability");

  script_xref(name:"URL", value:"http://www.securityfocus.com/bid/49937");
  script_xref(name:"URL", value:"http://www.ehcp.net");

  script_tag(name:"qod_type", value:"remote_vul");
  script_category(ACT_GATHER_INFO);
  script_family("Web application abuses");
  script_copyright("This script is Copyright (C) 2011 Greenbone Networks GmbH");
  script_dependencies("find_service.nasl", "http_version.nasl");
  script_require_ports("Services/www", 80);
  script_exclude_keys("Settings/disable_cgi_scanning");
  script_tag(name:"summary", value:"Easy Hosting Control Panel is prone to a security-bypass
vulnerability.

Attackers could exploit the issue to add arbitrary FTP accounts to the
affected application.

Easy Hosting Control Panel versions 0.29.10 up to and including
0.29.13 are vulnerable.");
  script_tag(name:"solution", value:"Upgrade to the latest version.");
  script_tag(name:"solution_type", value:"VendorFix");

  exit(0);
}

include("http_func.inc");
include("host_details.inc");
include("http_keepalive.inc");

port = get_http_port(default:80);

foreach dir( make_list_unique( "/", cgi_dirs( port:port ) ) ) {

  if( dir == "/" ) dir = "";
  url = string(dir, "/vhosts/ehcp/?op=applyforaccount");

  if(http_vuln_check(port:port, url:url,pattern:"Apply for ftp account",extra_check:'op=logout')) {
    report = report_vuln_url( port:port, url:url );
    security_message( port:port, data:report );
    exit( 0 );
  }
}

exit( 99 );