Lucene search

K
openvasCopyright (C) 2011 Greenbone Networks GmbHOPENVAS:1361412562310103113
HistoryMar 09, 2011 - 12:00 a.m.

PHP 'shmop_read()' Remote Integer Overflow Vulnerability

2011-03-0900:00:00
Copyright (C) 2011 Greenbone Networks GmbH
plugins.openvas.org
21

9.3 High

AI Score

Confidence

High

0.028 Low

EPSS

Percentile

90.6%

PHP is prone to an integer-overflow vulnerability because it
fails to ensure that integer values are not overrun.

# Copyright (C) 2011 Greenbone Networks GmbH
# Some text descriptions might be excerpted from (a) referenced
# source(s), and are Copyright (C) by the respective right holder(s).
#
# SPDX-License-Identifier: GPL-2.0-or-later
#
# This program is free software; you can redistribute it and/or
# modify it under the terms of the GNU General Public License
# as published by the Free Software Foundation; either version 2
# of the License, or (at your option) any later version.
#
# This program is distributed in the hope that it will be useful,
# but WITHOUT ANY WARRANTY; without even the implied warranty of
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
# GNU General Public License for more details.
#
# You should have received a copy of the GNU General Public License
# along with this program; if not, write to the Free Software
# Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA.

CPE = "cpe:/a:php:php";

if(description)
{
  script_oid("1.3.6.1.4.1.25623.1.0.103113");
  script_version("2022-04-28T13:38:57+0000");
  script_tag(name:"last_modification", value:"2022-04-28 13:38:57 +0000 (Thu, 28 Apr 2022)");
  script_tag(name:"creation_date", value:"2011-03-09 13:38:24 +0100 (Wed, 09 Mar 2011)");
  script_tag(name:"cvss_base", value:"7.5");
  script_tag(name:"cvss_base_vector", value:"AV:N/AC:L/Au:N/C:P/I:P/A:P");
  script_cve_id("CVE-2011-1092");
  script_name("PHP 'shmop_read()' Remote Integer Overflow Vulnerability");
  script_category(ACT_GATHER_INFO);
  script_family("Web application abuses");
  script_copyright("Copyright (C) 2011 Greenbone Networks GmbH");
  script_dependencies("secpod_php_smb_login_detect.nasl", "gb_php_ssh_login_detect.nasl", "gb_php_http_detect.nasl");
  script_mandatory_keys("php/detected");

  script_xref(name:"URL", value:"http://www.securityfocus.com/bid/46786");
  script_xref(name:"URL", value:"http://comments.gmane.org/gmane.comp.security.oss.general/4436");
  script_xref(name:"URL", value:"http://svn.php.net/viewvc/?view=revision&revision=309018");

  script_tag(name:"impact", value:"Successful exploits of this vulnerability allow remote attackers to
  execute arbitrary code in the context of a webserver affected by the
  issue. Failed attempts will likely result in denial-of-service conditions.");

  script_tag(name:"affected", value:"Versions prior to PHP 5.3.6 are vulnerable.");

  script_tag(name:"solution", value:"Updates are available. Please see the references for more information.");

  script_tag(name:"summary", value:"PHP is prone to an integer-overflow vulnerability because it
  fails to ensure that integer values are not overrun.");

  script_tag(name:"solution_type", value:"VendorFix");
  script_tag(name:"qod_type", value:"remote_banner_unreliable");

  exit(0);
}

include("version_func.inc");
include("host_details.inc");

if(isnull(port = get_app_port(cpe:CPE)))
  exit(0);

if(!vers = get_app_version(cpe:CPE, port:port))
  exit(0);

if(version_in_range(version:vers, test_version:"5.0", test_version2:"5.3.5")) {
  report = report_fixed_ver(installed_version:vers, fixed_version:"5.3.6");
  security_message(data:report, port:port);
  exit(0);
}

exit(99);

9.3 High

AI Score

Confidence

High

0.028 Low

EPSS

Percentile

90.6%