Lucene search

K
nvd[email protected]NVD:CVE-2023-45362
HistoryNov 03, 2023 - 5:15 a.m.

CVE-2023-45362

2023-11-0305:15:30
web.nvd.nist.gov
1
mediawiki
differenceengine.php
1.35.12
1.39.5
1.40.1
information leak

CVSS3

4.3

Attack Vector

NETWORK

Attack Complexity

LOW

Privileges Required

LOW

User Interaction

NONE

Scope

UNCHANGED

Confidentiality Impact

LOW

Integrity Impact

NONE

Availability Impact

NONE

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N

AI Score

5.5

Confidence

High

EPSS

0.001

Percentile

19.7%

An issue was discovered in DifferenceEngine.php in MediaWiki before 1.35.12, 1.36.x through 1.39.x before 1.39.5, and 1.40.x before 1.40.1. diff-multi-sameuser (aka “X intermediate revisions by the same user not shown”) ignores username suppression. This is an information leak.

Affected configurations

NVD
Node
mediawikimediawikiRange<1.35.12
OR
mediawikimediawikiRange1.36.0–1.39.5
OR
mediawikimediawikiMatch1.40.0-
OR
mediawikimediawikiMatch1.40.0rc0

CVSS3

4.3

Attack Vector

NETWORK

Attack Complexity

LOW

Privileges Required

LOW

User Interaction

NONE

Scope

UNCHANGED

Confidentiality Impact

LOW

Integrity Impact

NONE

Availability Impact

NONE

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N

AI Score

5.5

Confidence

High

EPSS

0.001

Percentile

19.7%