Lucene search

K
nvd[email protected]NVD:CVE-2011-4128
HistoryDec 08, 2011 - 8:55 p.m.

CVE-2011-4128

2011-12-0820:55:00
CWE-119
web.nvd.nist.gov
2

CVSS2

4.3

Attack Vector

NETWORK

Attack Complexity

MEDIUM

Authentication

NONE

Confidentiality Impact

NONE

Integrity Impact

NONE

Availability Impact

PARTIAL

AV:N/AC:M/Au:N/C:N/I:N/A:P

AI Score

8.8

Confidence

High

EPSS

0.003

Percentile

70.3%

Buffer overflow in the gnutls_session_get_data function in lib/gnutls_session.c in GnuTLS 2.12.x before 2.12.14 and 3.x before 3.0.7, when used on a client that performs nonstandard session resumption, allows remote TLS servers to cause a denial of service (application crash) via a large SessionTicket.

Affected configurations

NVD
Node
gnugnutlsMatch2.12.0
OR
gnugnutlsMatch2.12.1
OR
gnugnutlsMatch2.12.2
OR
gnugnutlsMatch2.12.3
OR
gnugnutlsMatch2.12.4
OR
gnugnutlsMatch2.12.5
OR
gnugnutlsMatch2.12.6
OR
gnugnutlsMatch2.12.6.1
OR
gnugnutlsMatch2.12.7
OR
gnugnutlsMatch2.12.8
OR
gnugnutlsMatch2.12.9
OR
gnugnutlsMatch2.12.10
OR
gnugnutlsMatch2.12.11
OR
gnugnutlsMatch2.12.12
OR
gnugnutlsMatch2.12.13
Node
gnugnutlsMatch3.0.0
OR
gnugnutlsMatch3.0.1
OR
gnugnutlsMatch3.0.2
OR
gnugnutlsMatch3.0.3
OR
gnugnutlsMatch3.0.4
OR
gnugnutlsMatch3.0.5
OR
gnugnutlsMatch3.0.6

CVSS2

4.3

Attack Vector

NETWORK

Attack Complexity

MEDIUM

Authentication

NONE

Confidentiality Impact

NONE

Integrity Impact

NONE

Availability Impact

PARTIAL

AV:N/AC:M/Au:N/C:N/I:N/A:P

AI Score

8.8

Confidence

High

EPSS

0.003

Percentile

70.3%