PHP 7.2.x < 7.2.29 Multiple Vulnerabilities

2020-03-24T00:00:00
ID WEB_APPLICATION_SCANNING_98993
Type nessus
Reporter This script is Copyright (C) 2020-2021 and is owned by Tenable, Inc. or an Affiliate thereof.
Modified 2021-09-07T00:00:00

Description

According to its banner, the version of PHP running on the remote web server is prior to 7.2.29, 7.3.x prior to 7.3.16, or 7.4.x prior to 7.4.4. It is, therefore, affected by multiple vulnerabilities: - An improper null termination exists in get_headers due to a silent truncation after a null byte. (CVE-2020-7066) - An out-of-bounds read error exists in exif due to the use of uninitialized value. (CVE-2020-7064) - A stack-based buffer overflow condition exists in php_unicode_tolower_full due to a call to mb_strtolower. (CVE-2020-7065) Note that the scanner has not tested for these issues but has instead relied only on the application's self-reported version number.

                                        
                                            No source data